*** NOTE IF YOU HAVE AN IT DEPARTMENT OR IT SERVICE PLEASE CONTACT THEM BEFORE MAKING CHANGES ***
Symptoms
Some users have been running into the issue where they cannot run an update on any of their desktop E-Catalogs. Generally is seen when the installer asks for permission and then proceeds to crash/fail without any warning or info. One other way to test to see if this the same issue, is to run the "Troubleshoot Compatibility" when right clicking on the downloaded installer and getting an error similar to the image below. (See images below)
Cause
While the the cause of this error is unknown, the suspicion is either a minor Windows bug that causes errors when attempting to access the %userprofile%\Appdata\Local\Temp directory or a cloud service (OneDrive, Dropbox, Google Drive, Etc) causing issues accessing this location.
How to fix
** IF YOU ARE UNSURE OF WHAT YOU ARE DOING PLEASE CONTACT YOUR IT OR CALL MILLWORK DEVELOPMENT FOR ASSISTANCE **
- Create a "Temp" folder in the root of the C Drive (C:\Temp)
- Open control panel and server Environment (upper right corner) and select "Edit environment variable for your account"
- Edit the TEMP & TMP variables by selecting edit in lower right of top box (Your value for these variables will be different than what is shown in screen shot)
- Select "Browse Directory," navigate and select Temp directory created in step 1 (Do this for both variables)
- Apply changes and try rerunning E-Catalog Update. If this was successful, your E-Catalog update should run through the installshield wizard and apply the update. If this does not fix the issue, it is advised that you change the variables back to their original location (%USERPROFILE%\AppData\Local\Temp) and contact Millwork Development Support for other troubleshooting steps.
If you are having trouble making these changes, or these changes did not solve your problem, Millwork Development Support will be happy to assist you in solving these issues. Millwork Development Support can be contacted at 612-999-4072 or emailed at support@millworkdevelopment.com.
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